Wednesday, July 03, 2013

Eclipse AWS Toolkit error Missing requirement: IdentityManagement

Error when installing Eclipse AWS Toolkit:

Cannot complete the install because one or more required items could not be found.
Software currently installed: AWS Toolkit for Eclipse Core 2.0.1.v201305021159 (com.amazonaws.eclipse.core.feature.feature.group 2.0.1.v201305021159)
Missing requirement: IdentityManagement 1.0.0.v201305021159 (com.amazonaws.eclipse.identitymanagement 1.0.0.v201305021159) requires 'bundle com.amazonaws.eclipse.ec2 1.1.0' but it could not be found
Cannot satisfy dependency:
From: AWS Toolkit for Eclipse Core 2.0.1.v201305021159 (com.amazonaws.eclipse.core.feature.feature.group 2.0.1.v201305021159)
To: com.amazonaws.eclipse.identitymanagement [1.0.0.v201305021159]
Resolution: Install EC2 Management first to get IdentityManagement.

5 comments:

Anonymous said...

thanks solved my problem!

Anonymous said...

Thank you for your help too. It solve this problem.

王志玮 said...

good. this solved aws' weird error.

Alber said...

Thanks! ;)

Curtis Forrester said...

Life-saver. Thanks! (Sad that this is still no poorly undocumented and handled by AWS)